You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by kazemi (Sep 5th 2005, 11:57am)

3 480

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by (Apr 9th 2006, 5:52pm)

3 478

by xpedient

(Jul 2nd 2006, 3:34pm)

by waboehly (May 1st 2007, 6:51am)

1 473

by Tom

(May 1st 2007, 3:34pm)

by Rmiclette (May 5th 2013, 6:49am)

2 472

by Scott76

(May 5th 2013, 11:41am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 464

by eddieruko

(Jul 30th 2014, 12:31pm)

by Terri (Jan 9th 2013, 6:46am)

1 464

by Wet_Boots

(Jan 9th 2013, 11:08am)

by blh (Jun 4th 2011, 12:55pm)

1 464

by Mitchgo

(Jun 4th 2011, 3:32pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 462

by jmduke7

(Aug 16th 2006, 6:30pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 457

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by handan (Nov 30th 2011, 11:30pm)

2 454

by handan

(Dec 2nd 2011, 4:56am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)