You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Rmiclette (May 5th 2013, 6:49am)

2 386

by Scott76

(May 5th 2013, 11:41am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 381

by PerryNZ

(Mar 14th 2014, 12:16am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 378

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by DRegs (May 5th 2010, 5:29pm)

1 376

by Wet_Boots

(May 6th 2010, 2:34pm)

by aa1872 (Mar 17th 2012, 8:22am)

3 375

by GatorGuy

(Mar 19th 2012, 8:41am)

by sanddido (Oct 11th 2007, 3:39am)

1 373

by mrfixit

(Oct 11th 2007, 2:03pm)

by bcampy1 (Jun 15th 2007, 11:06am)

0 372

No reply

by bobspitler (Jun 6th 2011, 7:10am)

1 370

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Sue (Aug 11th 2005, 10:47am)

4 370

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by handan (Nov 30th 2011, 11:30pm)

2 367

by handan

(Dec 2nd 2011, 4:56am)

Show

Statistics:

469 Threads - 1,749 Posts (average 0.36 Posts per Day)