You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 232

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 191

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Binks (Apr 10th 2013, 1:28am)

1 176

by mrfixit

(Apr 10th 2013, 3:02am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 377

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Terri (Jan 9th 2013, 6:46am)

1 289

by Wet_Boots

(Jan 9th 2013, 11:08am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 372

by Wet_Boots

(Dec 26th 2012, 8:32am)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 423

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 736

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 450

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 446

by Wet_Boots

(Aug 30th 2012, 4:50pm)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)