You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by George_S (Jun 26th 2009, 7:13pm)

0 177

No reply

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 188

by Wet_Boots

(Jun 26th 2009, 8:58am)

by EtzGx (Jun 21st 2009, 12:40pm)

0 423

No reply

by bbruck (Jun 20th 2009, 7:11pm)

1 292

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 149

by hi.todd

(Jun 19th 2009, 10:29pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 90

by hi.todd

(Jun 19th 2009, 10:27pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 257

by hi.todd

(Jun 19th 2009, 10:24pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 122

by hi.todd

(Jun 19th 2009, 10:23pm)

by larbec7 (Jun 6th 2009, 5:07pm)

9 730

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by killerj (May 25th 2009, 10:32am)

0 172

No reply

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)