You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Ryanm519 (Jun 16th 2011, 1:28am)

1 431

by Wet_Boots

(Jun 16th 2011, 6:25am)

by rspfau (Jun 9th 2011, 6:12pm)

4 672

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 494

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 573

by Wet_Boots

(Jun 9th 2011, 10:09am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 723

by ddeferra

(Jun 8th 2011, 6:29pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 354

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 284

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 379

by Mitchgo

(Jun 4th 2011, 3:32pm)

by runningfreak (May 25th 2011, 7:32pm)

1 249

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 403

by Mitchgo

(May 9th 2011, 1:04am)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)