You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JohnEmery (Jul 31st 2011, 3:48pm)

1 450

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by water (Oct 23rd 2008, 8:47am)

1 451

by mrfixit

(Oct 23rd 2008, 10:24am)

by Metalman1 (May 23rd 2011, 11:56am)

3 452

by sharon

(May 30th 2011, 12:20pm)

by criceX (May 20th 2011, 9:34pm)

2 452

by criceX

(May 21st 2011, 7:03pm)

by quick11 (Oct 7th 2010, 10:53am)

3 452

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by macminn (Jun 11th 2007, 5:43pm)

2 452

by mrfixit

(Jun 7th 2008, 8:13am)

by OscarNav (Apr 17th 2005, 8:54pm)

2 455

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by jack z (Apr 8th 2012, 10:35am)

1 456

by mrfixit

(Apr 8th 2012, 2:37pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 456

by Mitchgo

(Jul 19th 2011, 12:34am)

by dkraska (Aug 29th 2009, 2:41pm)

4 460

by hi.todd

(Aug 30th 2009, 9:32pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)