You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jeffg (Oct 22nd 2011, 6:06pm)

1 449

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by lydiaE (Jun 25th 2009, 11:39am)

1 449

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by joe13 (Aug 19th 2012, 12:36pm)

1 451

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by miker (Apr 30th 2011, 12:53pm)

1 451

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by Mitchell (Feb 27th 2011, 2:26pm)

1 454

by hi.todd

(Feb 27th 2011, 4:12pm)

by tico (Jun 15th 2013, 8:58pm)

0 460

No reply

by dwinmac (Sep 4th 2010, 2:42pm)

3 461

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by avu3 (Jul 3rd 2005, 2:36pm)

4 462

by avu3

(Jul 4th 2005, 7:20pm)

by sgb (Jun 5th 2006, 5:30pm)

0 463

No reply

by mulletmac (Sep 30th 2011, 7:29am)

2 468

by mulletmac

(Oct 1st 2011, 11:26am)

Show

Statistics:

468 Threads - 1,710 Posts (average 0.36 Posts per Day)