You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 377

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Metalman1 (May 23rd 2011, 11:56am)

3 378

by sharon

(May 30th 2011, 12:20pm)

by Marlene (Aug 23rd 2007, 3:11am)

4 378

by Marlene

(Aug 25th 2007, 5:42am)

by dkraska (Aug 29th 2009, 2:41pm)

4 380

by hi.todd

(Aug 30th 2009, 9:32pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 382

by Mitchgo

(Jul 19th 2011, 12:34am)

by ros (Mar 15th 2012, 7:40pm)

1 383

by hi.todd

(Mar 20th 2012, 9:07pm)

by dgergits (Aug 29th 2010, 10:02am)

0 386

No reply

by OscarNav (Apr 17th 2005, 8:54pm)

2 387

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 388

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 388

No reply

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)