You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mydogcleo (Aug 28th 2013, 10:11am)

1 228

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 567

by mrfixit

(Nov 10th 2011, 4:23am)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,019

by jmduke7

(Aug 17th 2006, 3:00pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,105

by Mitchgo

(Jun 12th 2011, 2:13pm)

by John199 (Aug 14th 2011, 3:57pm)

4 631

by hi.todd

(Aug 15th 2011, 7:29pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 659

by crashxx

(May 1st 2012, 9:15am)

by brobinson (Jun 12th 2010, 7:44am)

8 1,920

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 714

by jmduke7

(Aug 17th 2006, 3:13pm)

by JimB (Jul 30th 2011, 3:59pm)

1 130

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 331

by Wet_Boots

(Sep 5th 2010, 2:55pm)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)