You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Lainiest (Jul 2nd 2012, 7:11pm)

2 549

by GatorGuy

(Jul 3rd 2012, 8:00am)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 1,097

by GatorGuy

(Jun 12th 2012, 8:36am)

by dse (Jun 8th 2012, 5:58am)

2 675

by Wet_Boots

(Jun 8th 2012, 8:48am)

by AdamT (Jun 7th 2012, 12:00pm)

2 525

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 472

by hi.todd

(Jun 1st 2012, 8:55pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 617

by GatorGuy

(May 21st 2012, 9:04am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 414

by GatorGuy

(Apr 23rd 2012, 8:47am)

by mack (Apr 18th 2012, 8:30pm)

2 857

by mack

(Apr 19th 2012, 12:54pm)

by opsec (Apr 1st 2012, 7:44pm)

2 844

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by handan (Nov 30th 2011, 11:30pm)

2 568

by handan

(Dec 2nd 2011, 4:56am)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)