You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by slugbugblue (Jul 16th 2010, 6:40am)

2 298

by Wet_Boots

(Jul 17th 2010, 9:11am)

by RodQ (Jul 11th 2010, 12:54pm)

2 292

by hi.todd

(Jul 12th 2010, 12:49pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,219

by PhoenixDen

(Jun 24th 2010, 11:27am)

by Greenweenie (Jun 21st 2010, 9:15am)

2 3,626

by Greenweenie

(Jun 22nd 2010, 8:30am)

by stillc (Jul 29th 2009, 12:36pm)

2 823

by Wet_Boots

(Aug 4th 2009, 1:08am)

by d leimer (Jun 14th 2009, 11:45pm)

2 440

by hi.todd

(Jun 19th 2009, 10:24pm)

by Brie (Feb 24th 2009, 11:42am)

2 709

by sanzen96

(Mar 21st 2009, 3:55pm)

by macminn (Jun 11th 2007, 5:43pm)

2 553

by mrfixit

(Jun 7th 2008, 8:13am)

by tmshead (Oct 1st 2007, 4:35am)

2 464

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 442

by Wet_Boots

(Sep 16th 2007, 7:55am)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)