You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by richard1975 (Apr 28th 2013, 7:12pm)

1 329

by Scott76

(May 2nd 2013, 2:06pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 380

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 335

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 434

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Binks (Apr 10th 2013, 1:28am)

1 318

by mrfixit

(Apr 10th 2013, 3:02am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 625

by Wet_Boots

(Mar 12th 2013, 11:42am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 467

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Terri (Jan 9th 2013, 6:46am)

1 428

by Wet_Boots

(Jan 9th 2013, 11:08am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 523

by Wet_Boots

(Dec 26th 2012, 8:32am)

by rockypoint (Nov 26th 2012, 6:02pm)

2 702

by mrfixit

(Nov 26th 2012, 7:30pm)

Show

Statistics:

474 Threads - 1,780 Posts (average 0.36 Posts per Day)