You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Moggie (Jun 4th 2011, 10:48am)

1 252

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 340

by Mitchgo

(Jun 4th 2011, 3:32pm)

by rbuchas (May 27th 2011, 2:22pm)

8 1,621

by hi.todd

(Jun 3rd 2011, 4:52pm)

by runningfreak (May 25th 2011, 7:32pm)

1 211

by Wet_Boots

(May 25th 2011, 8:29pm)

by criceX (May 20th 2011, 9:34pm)

2 428

by criceX

(May 21st 2011, 7:03pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 352

by Mitchgo

(May 9th 2011, 1:04am)

by Wet_Boots (May 8th 2011, 7:43am)

0 264

No reply

by krantzr (Apr 30th 2011, 8:26am)

3 1,153

by mrfixit

(May 1st 2011, 11:34am)

by miker (Apr 30th 2011, 12:53pm)

1 390

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 608

by Wet_Boots

(Apr 26th 2011, 9:20am)

Show

Statistics:

438 Threads - 1,662 Posts (average 0.36 Posts per Day)