You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tbtech24 (Jun 9th 2011, 9:24am)

3 499

by Wet_Boots

(Jun 9th 2011, 10:09am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 444

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 558

by Mitchgo

(Jun 9th 2011, 10:08pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,258

by Mitchgo

(Jun 12th 2011, 2:13pm)

by jackh (Jun 12th 2011, 11:57am)

9 2,694

by Wet_Boots

(Jun 13th 2011, 9:17am)

by pillboy (Jun 8th 2011, 6:40pm)

11 2,990

by Wet_Boots

(Jun 14th 2011, 2:26pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 380

by Wet_Boots

(Jun 16th 2011, 6:25am)

by Val (Jun 17th 2011, 10:57pm)

4 258

by Val

(Jun 18th 2011, 7:07pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 247

No reply

by ncampbel (Jul 1st 2011, 2:15pm)

1 665

by Mitchgo

(Jul 1st 2011, 9:20pm)

Show

Statistics:

436 Threads - 1,652 Posts (average 0.36 Posts per Day)