You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by criceX (May 20th 2011, 9:34pm)

2 383

by criceX

(May 21st 2011, 7:03pm)

by runningfreak (May 25th 2011, 7:32pm)

1 187

by Wet_Boots

(May 25th 2011, 8:29pm)

by Metalman1 (May 23rd 2011, 11:56am)

3 396

by sharon

(May 30th 2011, 12:20pm)

by kxaz145 (May 1st 2009, 2:52pm)

3 1,213

by Wet_Boots

(Jun 3rd 2011, 7:49am)

by rbuchas (May 27th 2011, 2:22pm)

8 1,528

by hi.todd

(Jun 3rd 2011, 4:52pm)

by blh (Jun 4th 2011, 12:55pm)

1 316

by Mitchgo

(Jun 4th 2011, 3:32pm)

by Moggie (Jun 4th 2011, 10:48am)

1 235

by Mitchgo

(Jun 5th 2011, 1:28pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 292

by Mitchgo

(Jun 6th 2011, 9:34pm)

by bherholz (May 16th 2011, 12:06pm)

5 987

by mrfixit

(Jun 7th 2011, 5:46pm)

by ddeferra (Jun 7th 2011, 10:46pm)

2 616

by ddeferra

(Jun 8th 2011, 6:29pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)