You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Cherrybark (May 20th 2012, 6:22pm)

2 356

by GatorGuy

(May 21st 2012, 9:04am)

by blh (Jun 4th 2011, 12:55pm)

1 355

by Mitchgo

(Jun 4th 2011, 3:32pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 354

by Wet_Boots

(May 2nd 2005, 2:02am)

by Terri (Jan 9th 2013, 6:46am)

1 353

by Wet_Boots

(Jan 9th 2013, 11:08am)

by paterjb (Jan 5th 2004, 7:46am)

5 351

by RVLI

(Jan 6th 2004, 3:16pm)

by raisbarth (Feb 26th 2012, 9:14am)

0 350

No reply

by ohiorebel (Apr 10th 2011, 8:59am)

2 348

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 346

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 345

by Mitchgo

(Jul 25th 2011, 11:12pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 338

by jmduke7

(Aug 16th 2006, 6:30pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)