You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 400

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 400

by hi.todd

(Jun 19th 2009, 10:24pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 400

by hi.todd

(Apr 6th 2008, 5:05pm)

by binki3 (Aug 29th 2005, 10:33am)

3 400

by RidgeRun05

(Aug 30th 2005, 11:16am)

by Texas_Pete (May 1st 2005, 7:21pm)

1 400

by Wet_Boots

(May 2nd 2005, 2:02am)

by Terri (Jan 9th 2013, 6:46am)

1 394

by Wet_Boots

(Jan 9th 2013, 11:08am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 393

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by raisbarth (Feb 26th 2012, 9:14am)

0 393

No reply

by ohiorebel (Apr 10th 2011, 8:59am)

2 389

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 388

by GatorGuy

(May 21st 2012, 9:04am)

Show

Statistics:

437 Threads - 1,666 Posts (average 0.35 Posts per Day)