You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by binki3 (Aug 29th 2005, 10:33am)

3 366

by RidgeRun05

(Aug 30th 2005, 11:16am)

by Texas_Pete (May 1st 2005, 7:21pm)

1 366

by Wet_Boots

(May 2nd 2005, 2:02am)

by paterjb (Jan 5th 2004, 7:46am)

5 364

by RVLI

(Jan 6th 2004, 3:16pm)

by blh (Jun 4th 2011, 12:55pm)

1 360

by Mitchgo

(Jun 4th 2011, 3:32pm)

by Terri (Jan 9th 2013, 6:46am)

1 359

by Wet_Boots

(Jan 9th 2013, 11:08am)

by Cherrybark (May 20th 2012, 6:22pm)

2 357

by GatorGuy

(May 21st 2012, 9:04am)

by ohiorebel (Apr 10th 2011, 8:59am)

2 354

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 353

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 350

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 349

by Mitchgo

(Jul 25th 2011, 11:12pm)

Show

Statistics:

461 Threads - 1,706 Posts (average 0.37 Posts per Day)