You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SteveM099 (Jun 19th 2006, 1:50am)

1 180

by Wet_Boots

(Jun 19th 2006, 6:17am)

by boba (Jul 25th 2005, 7:26am)

0 104

No reply

by runningfreak (May 25th 2011, 7:32pm)

1 179

by Wet_Boots

(May 25th 2011, 8:29pm)

by desmo907 (Aug 28th 2012, 3:54pm)

3 394

by desmo907

(Sep 4th 2012, 8:33am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 147

by evergreenz

(Sep 3rd 2011, 12:08pm)

by martinjames10 (Nov 10th 2004, 8:57am)

5 251

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 440

by s123mith

(Jul 10th 2012, 5:21am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 228

by Wet_Boots

(Jun 26th 2009, 8:58am)

by noquarter (May 24th 2014, 1:22pm)

6 74

by Wet_Boots

(May 26th 2014, 6:22am)

by bherholz (May 16th 2011, 12:06pm)

5 953

by mrfixit

(Jun 7th 2011, 5:46pm)

Show

Statistics:

432 Threads - 1,632 Posts (average 0.36 Posts per Day)