You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fwoodall (Aug 28th 2005, 6:01pm)

2 1,212

by squints

(Jul 31st 2011, 2:16pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 494

by Mitchgo

(Jul 25th 2011, 11:12pm)

by mijd (Jul 20th 2011, 2:56pm)

2 552

by Mitchgo

(Jul 23rd 2011, 3:45am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 777

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 594

by Mitchgo

(Jul 11th 2011, 12:24am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,063

by ddeferra

(Jun 8th 2011, 6:29pm)

by criceX (May 20th 2011, 9:34pm)

2 708

by criceX

(May 21st 2011, 7:03pm)

by ohiorebel (Apr 10th 2011, 8:59am)

2 544

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by orgits (Apr 9th 2011, 5:10pm)

2 1,263

by Mitchgo

(Apr 10th 2011, 2:29am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 385

by Wet_Boots

(Sep 28th 2010, 1:11pm)

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)