You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lloydlevy (Nov 28th 2011, 1:34pm)

1 209

by Wet_Boots

(Nov 28th 2011, 3:46pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 695

by Wet_Boots

(Nov 13th 2011, 8:15am)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 770

by mrfixit

(Nov 10th 2011, 4:23am)

by RC (Nov 6th 2011, 7:46pm)

2 305

by Wet_Boots

(Nov 7th 2011, 7:57am)

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 236

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by mdige (Oct 31st 2011, 4:31pm)

1 812

by Wet_Boots

(Nov 1st 2011, 6:36am)

by Neil7 (Oct 24th 2011, 5:19pm)

5 421

by Neil7

(Oct 25th 2011, 8:44pm)

by jeffg (Oct 22nd 2011, 6:06pm)

1 452

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 419

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by bdt (Oct 17th 2011, 9:50am)

2 481

by Mitchgo

(Oct 17th 2011, 12:59pm)

Show

Statistics:

469 Threads - 1,749 Posts (average 0.36 Posts per Day)