You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by DAVID LP (Jul 18th 2011, 10:55am)

2 353

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 356

by Wet_Boots

(Jun 16th 2011, 6:25am)

by sgb (Jun 5th 2006, 5:30pm)

0 357

No reply

by gobris (May 14th 2013, 9:45am)

3 358

by Wet_Boots

(May 16th 2013, 8:30am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 360

by Brassguy

(Mar 8th 2012, 10:09pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 360

by mulletmac

(Oct 1st 2011, 11:26am)

by criceX (May 20th 2011, 9:34pm)

2 360

by criceX

(May 21st 2011, 7:03pm)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 362

by CRI IRR

(Sep 13th 2011, 6:34am)

by dunn (Jun 29th 2005, 3:35am)

4 365

by Wet_Boots

(Jul 4th 2005, 6:22am)

by jeffg (Oct 22nd 2011, 6:06pm)

1 366

by Wet_Boots

(Oct 23rd 2011, 11:52am)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)