You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 374

by mrfixit

(Jul 14th 2012, 12:39am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 374

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 375

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by cassian (Jul 31st 2005, 2:39pm)

4 375

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by jeffg (Oct 22nd 2011, 6:06pm)

1 376

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by macminn (May 18th 2007, 5:05pm)

9 376

by SprinklerGuy

(May 25th 2007, 3:19am)

by sgb (Jun 5th 2006, 5:30pm)

0 378

No reply

by lydiaE (Jun 25th 2009, 11:39am)

1 379

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Bumbleball (Sep 4th 2010, 12:15am)

10 381

by Bumbleball

(Sep 14th 2010, 9:06pm)

by Brassguy (Feb 26th 2012, 4:36pm)

5 382

by Brassguy

(Mar 8th 2012, 10:09pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)