You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Mitchell (Feb 27th 2011, 2:26pm)

1 457

by hi.todd

(Feb 27th 2011, 4:12pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 457

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by miker (Apr 30th 2011, 12:53pm)

1 462

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by joe13 (Aug 19th 2012, 12:36pm)

1 465

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by sgb (Jun 5th 2006, 5:30pm)

0 466

No reply

by dwinmac (Sep 4th 2010, 2:42pm)

3 470

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by avu3 (Jul 3rd 2005, 2:36pm)

4 472

by avu3

(Jul 4th 2005, 7:20pm)

by dgergits (Aug 29th 2010, 10:02am)

0 475

No reply

by mulletmac (Sep 30th 2011, 7:29am)

2 477

by mulletmac

(Oct 1st 2011, 11:26am)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 480

by mrfixit

(Dec 4th 2010, 1:48pm)

Show

Statistics:

469 Threads - 1,749 Posts (average 0.36 Posts per Day)