You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Neil7 (Oct 24th 2011, 5:19pm)

5 406

by Neil7

(Oct 25th 2011, 8:44pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 405

by Mitchgo

(May 9th 2011, 1:04am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 403

by Wet_Boots

(Sep 16th 2007, 7:55am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 401

by mrfixit

(Jun 25th 2013, 8:32pm)

by jackevln (Aug 20th 2006, 6:33am)

4 401

by mrfixit

(Aug 21st 2006, 5:12pm)

by hettiep (May 27th 2005, 5:02am)

2 401

by Jazzer K

(Sep 2nd 2005, 6:22pm)

by paterjb (Jan 5th 2004, 7:46am)

5 401

by RVLI

(Jan 6th 2004, 3:16pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 400

by mrfixit

(Aug 14th 2013, 12:28pm)

by waboehly (May 1st 2007, 6:51am)

1 400

by Tom

(May 1st 2007, 3:34pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 399

by hi.todd

(Apr 6th 2008, 5:05pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)