You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dse (Jun 8th 2012, 5:58am)

2 635

by Wet_Boots

(Jun 8th 2012, 8:48am)

by AdamT (Jun 7th 2012, 12:00pm)

2 493

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 442

by hi.todd

(Jun 1st 2012, 8:55pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 576

by GatorGuy

(May 21st 2012, 9:04am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 385

by GatorGuy

(Apr 23rd 2012, 8:47am)

by mack (Apr 18th 2012, 8:30pm)

2 828

by mack

(Apr 19th 2012, 12:54pm)

by opsec (Apr 1st 2012, 7:44pm)

2 804

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by handan (Nov 30th 2011, 11:30pm)

2 535

by handan

(Dec 2nd 2011, 4:56am)

by RC (Nov 6th 2011, 7:46pm)

2 487

by Wet_Boots

(Nov 7th 2011, 7:57am)

by bdt (Oct 17th 2011, 9:50am)

2 642

by Mitchgo

(Oct 17th 2011, 12:59pm)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)