You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Greenweenie (Jun 21st 2010, 9:15am)

2 2,938

by Greenweenie

(Jun 22nd 2010, 8:30am)

by stillc (Jul 29th 2009, 12:36pm)

2 754

by Wet_Boots

(Aug 4th 2009, 1:08am)

by d leimer (Jun 14th 2009, 11:45pm)

2 380

by hi.todd

(Jun 19th 2009, 10:24pm)

by Brie (Feb 24th 2009, 11:42am)

2 650

by sanzen96

(Mar 21st 2009, 3:55pm)

by macminn (Jun 11th 2007, 5:43pm)

2 482

by mrfixit

(Jun 7th 2008, 8:13am)

by tmshead (Oct 1st 2007, 4:35am)

2 418

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 385

by Wet_Boots

(Sep 16th 2007, 7:55am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 237

by abhnoclue

(Jun 17th 2007, 6:20am)

by pstruh (Jun 7th 2007, 7:58pm)

2 571

by mrfixit

(Jun 8th 2007, 9:45pm)

by guill34 (Jun 4th 2007, 6:49am)

2 838

by guill34

(Jun 4th 2007, 1:11pm)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.35 Posts per Day)