You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by trs (Aug 4th 2015, 7:38pm)

2 1,289

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 217

by LX2

(Jul 17th 2015, 8:27am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 248

by Eowilcox

(Jun 18th 2015, 2:23pm)

by zsac09 (Jun 8th 2015, 2:57pm)

2 298

by zsac09

(Jun 10th 2015, 3:26pm)

by EricJRW (May 6th 2015, 8:09pm)

2 228

by EricJRW

(May 7th 2015, 7:04am)

by jerr7 (May 4th 2015, 4:35pm)

2 152

by jerr7

(May 6th 2015, 11:08am)

by fouracreDon (Mar 17th 2015, 8:09am)

2 300

by carlanw

(Apr 27th 2015, 10:52pm)

by wileyb (Mar 23rd 2015, 4:00pm)

2 698

by Wet_Boots

(Mar 24th 2015, 9:18am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 538

by eddieruko

(Jul 30th 2014, 12:31pm)

by Benmt (Jul 24th 2014, 11:01pm)

2 265

by Benmt

(Jul 25th 2014, 1:46pm)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)