You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jimmyburg (Nov 19th 2007, 6:27am)

1 308

by hi.todd

(Apr 6th 2008, 5:05pm)

by crazydayz (Oct 17th 2007, 6:33am)

0 247

No reply

by sanddido (Oct 11th 2007, 3:39am)

1 282

by mrfixit

(Oct 11th 2007, 2:03pm)

by tmshead (Oct 1st 2007, 4:35am)

2 345

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 265

No reply

by Dan Mueller (Sep 15th 2007, 3:45am)

2 303

by Wet_Boots

(Sep 16th 2007, 7:55am)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 221

by Wet_Boots

(Sep 15th 2007, 12:31am)

by perplexed (Sep 8th 2007, 3:35am)

4 479

by perplexed

(Sep 9th 2007, 5:20am)

by Marlene (Aug 23rd 2007, 3:11am)

4 379

by Marlene

(Aug 25th 2007, 5:42am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 206

by jmduke7

(Aug 7th 2007, 11:20am)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)