You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by g (Apr 19th 2011, 1:56pm)

0 170

No reply

by jchsmiller (Apr 18th 2011, 11:47am)

1 270

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by wrx884 (Apr 22nd 2011, 12:57am)

5 1,144

by Wet_Boots

(Apr 25th 2011, 9:37am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 391

No reply

by ianmac (Apr 25th 2011, 10:45pm)

1 560

by Wet_Boots

(Apr 26th 2011, 9:20am)

by miker (Apr 30th 2011, 12:53pm)

1 356

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by krantzr (Apr 30th 2011, 8:26am)

3 1,075

by mrfixit

(May 1st 2011, 11:34am)

by JA (May 9th 2010, 11:27am)

7 4,532

by Wet_Boots

(May 3rd 2011, 6:55am)

by Wet_Boots (May 8th 2011, 7:43am)

0 242

No reply

by AZHomeOwner (May 7th 2011, 1:35pm)

1 322

by Mitchgo

(May 9th 2011, 1:04am)

Show

Statistics:

434 Threads - 1,639 Posts (average 0.36 Posts per Day)