You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dwinmac (Sep 4th 2010, 2:42pm)

3 680

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by stktrader (May 20th 2012, 5:55pm)

4 679

by Wet_Boots

(May 21st 2012, 7:02am)

by jack z (Apr 8th 2012, 10:35am)

1 678

by mrfixit

(Apr 8th 2012, 2:37pm)

by paul b (Jul 3rd 2010, 10:24am)

1 678

by Wet_Boots

(Jul 6th 2010, 9:21am)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 677

by mrfixit

(Aug 14th 2013, 12:28pm)

by Max (May 6th 2007, 8:27pm)

2 671

by Tom

(May 9th 2007, 3:29am)

by EtzGx (Jun 21st 2009, 12:40pm)

0 669

No reply

by Neil7 (Oct 24th 2011, 5:19pm)

5 667

by Neil7

(Oct 25th 2011, 8:44pm)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 664

by Wet_Boots

(Dec 26th 2012, 8:32am)

by bdt (Oct 17th 2011, 9:50am)

2 663

by Mitchgo

(Oct 17th 2011, 12:59pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)