You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tico (Jun 15th 2013, 8:58pm)

0 305

No reply

by AZHomeOwner (May 7th 2011, 1:35pm)

1 303

by Mitchgo

(May 9th 2011, 1:04am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 300

by hi.todd

(Feb 27th 2011, 4:12pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 300

by hi.todd

(Apr 6th 2008, 5:05pm)

by Merv (May 1st 2010, 3:44pm)

3 299

by mrfixit

(May 31st 2010, 9:47pm)

by blh (Jun 4th 2011, 12:55pm)

1 297

by Mitchgo

(Jun 4th 2011, 3:32pm)

by joe13 (Aug 19th 2012, 12:36pm)

1 296

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 295

by Wet_Boots

(Sep 16th 2007, 7:55am)

by Texas_Pete (May 1st 2005, 7:21pm)

1 293

by Wet_Boots

(May 2nd 2005, 2:02am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 292

No reply

Show

Statistics:

429 Threads - 1,622 Posts (average 0.36 Posts per Day)