You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 283

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by Merv (May 1st 2010, 3:44pm)

3 282

by mrfixit

(May 31st 2010, 9:47pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 282

by Wet_Boots

(Sep 16th 2007, 7:55am)

by gobris (May 14th 2013, 9:45am)

3 279

by Wet_Boots

(May 16th 2013, 8:30am)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 278

by Mitchgo

(May 9th 2011, 1:04am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 277

No reply

by hettiep (May 27th 2005, 5:02am)

2 274

by Jazzer K

(Sep 2nd 2005, 6:22pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 274

by Wet_Boots

(May 2nd 2005, 2:02am)

by Cherrybark (May 20th 2012, 6:22pm)

2 273

by GatorGuy

(May 21st 2012, 9:04am)

by joe13 (Aug 19th 2012, 12:36pm)

1 265

by Wet_Boots

(Aug 19th 2012, 2:35pm)

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)