You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mydogcleo (Aug 28th 2013, 10:11am)

1 546

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by LT87 (May 21st 2014, 11:33am)

3 288

by hi.todd

(May 27th 2014, 1:03pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 791

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by Fapp (Feb 21st 2005, 10:11am)

3 1,138

by nestors

(Apr 7th 2005, 8:51am)

by fireman (Sep 15th 2006, 3:14pm)

8 1,028

by mrfixit

(Sep 19th 2006, 9:59am)

by 206007075 (Sep 28th 2004, 10:26am)

0 648

No reply

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 413

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by modetz (Jun 16th 2012, 11:23am)

1 504

by Wet_Boots

(Jun 16th 2012, 12:29pm)

by lalloo (Aug 5th 2012, 11:02am)

2 418

by GatorGuy

(Aug 6th 2012, 9:13am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 446

by abhnoclue

(Jun 17th 2007, 6:20am)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)