You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Brie (Feb 24th 2009, 11:42am)

2 566

by sanzen96

(Mar 21st 2009, 3:55pm)

by macminn (Jun 11th 2007, 5:43pm)

2 393

by mrfixit

(Jun 7th 2008, 8:13am)

by tmshead (Oct 1st 2007, 4:35am)

2 349

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 307

by Wet_Boots

(Sep 16th 2007, 7:55am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 175

by abhnoclue

(Jun 17th 2007, 6:20am)

by pstruh (Jun 7th 2007, 7:58pm)

2 497

by mrfixit

(Jun 8th 2007, 9:45pm)

by guill34 (Jun 4th 2007, 6:49am)

2 733

by guill34

(Jun 4th 2007, 1:11pm)

by david28 (May 28th 2007, 3:46am)

2 478

by david28

(May 28th 2007, 5:55pm)

by Max (May 6th 2007, 8:27pm)

2 381

by Tom

(May 9th 2007, 3:29am)

by Mikeee (Apr 22nd 2007, 9:24am)

2 723

by jmduke7

(Apr 22nd 2007, 2:21pm)

Show

Statistics:

432 Threads - 1,632 Posts (average 0.36 Posts per Day)