You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by BostonStrong (Apr 26th 2016, 5:45pm)

3 97

by BostonStrong

(Apr 27th 2016, 8:33pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 195

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by ChucksLandscaping (Apr 20th 2016, 11:19am)

0 41

No reply

by cmoore (Mar 27th 2016, 6:32am)

3 237

by Wet_Boots

(Apr 2nd 2016, 10:52am)

by rebuild_Nate (Mar 24th 2016, 7:21pm)

7 171

by Wet_Boots

(Mar 30th 2016, 7:12pm)

by Rey@@%% (Mar 26th 2016, 12:04pm)

0 40

No reply

by irafish (Mar 18th 2016, 11:44am)

1 102

by Wet_Boots

(Mar 22nd 2016, 5:50pm)

by kp007 (Mar 22nd 2016, 10:42am)

3 54

by Wet_Boots

(Mar 22nd 2016, 12:35pm)

by Dagobah (Mar 19th 2016, 5:23pm)

0 91

No reply

by BayAreaFlyer (Feb 9th 2016, 2:17pm)

2 466

by Wet_Boots

(Feb 9th 2016, 5:28pm)

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)