You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by tbruce (Sep 16th 2016, 9:54am)

1 69

by mrfixit

(Sep 16th 2016, 2:29pm)

by rainman?? (Aug 12th 2016, 12:17pm)

0 349

No reply

by Nitram (Aug 12th 2016, 6:49am)

2 125

by Nitram

(Aug 12th 2016, 10:49am)

by simmons214 (Aug 4th 2016, 7:58am)

4 161

by mrfixit

(Aug 5th 2016, 1:52am)

by mrfixit (Aug 2nd 2016, 12:47am)

1 98

by Wet_Boots

(Aug 2nd 2016, 9:06am)

by richlane (Aug 1st 2016, 4:22pm)

1 86

by mrfixit

(Aug 1st 2016, 8:28pm)

by TNL (Jul 20th 2016, 11:52am)

9 201

by mrfixit

(Jul 22nd 2016, 5:01am)

by Danielleusf (Jul 8th 2016, 3:53pm)

1 258

by hi.todd

(Jul 8th 2016, 7:03pm)

by hotshot (Jun 30th 2016, 11:50am)

2 177

by SunCoLawns

(Jun 30th 2016, 5:34pm)

by Chrism (Jun 25th 2016, 3:20pm)

5 125

by Wet_Boots

(Jun 26th 2016, 8:01am)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)