You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Bumbleball (Sep 4th 2010, 12:15am)

10 450

by Bumbleball

(Sep 14th 2010, 9:06pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 463

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 389

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by sci4kids (Sep 4th 2010, 9:48am)

2 548

by hi.todd

(Sep 4th 2010, 11:45am)

by RedArt (Aug 15th 2010, 11:03am)

3 1,556

by mrfixit

(Aug 31st 2010, 2:23pm)

by dgergits (Aug 29th 2010, 10:02am)

0 426

No reply

by billt (Aug 28th 2010, 10:20am)

1 211

by Wet_Boots

(Aug 28th 2010, 11:21am)

by kenken55 (Aug 5th 2010, 10:55am)

2 497

by kenken1955

(Aug 28th 2010, 5:32am)

by beanpole (Aug 21st 2010, 10:20pm)

5 907

by Wet_Boots

(Aug 24th 2010, 12:57pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 663

by mrfixit

(Aug 12th 2010, 5:12pm)

Show

Statistics:

438 Threads - 1,662 Posts (average 0.36 Posts per Day)