You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by billt (Aug 28th 2010, 10:20am)

1 653

by Wet_Boots

(Aug 28th 2010, 11:21am)

by dgergits (Aug 29th 2010, 10:02am)

0 647

No reply

by RedArt (Aug 15th 2010, 11:03am)

3 2,357

by mrfixit

(Aug 31st 2010, 2:23pm)

by sci4kids (Sep 4th 2010, 9:48am)

2 835

by hi.todd

(Sep 4th 2010, 11:45am)

by dwinmac (Sep 4th 2010, 2:42pm)

3 696

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 801

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by Bumbleball (Sep 4th 2010, 12:15am)

10 1,608

by Bumbleball

(Sep 14th 2010, 9:06pm)

by t_shea (Sep 18th 2010, 10:46am)

5 3,721

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by shakeum (Sep 19th 2010, 8:50pm)

5 1,057

by Wet_Boots

(Sep 25th 2010, 7:21am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 455

by Wet_Boots

(Sep 28th 2010, 1:11pm)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)