You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by waboehly (May 1st 2007, 6:51am)

1 333

by Tom

(May 1st 2007, 3:34pm)

by Merv (May 1st 2010, 3:44pm)

3 335

by mrfixit

(May 31st 2010, 9:47pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 338

by Mitchgo

(May 9th 2011, 1:04am)

by Pippilo (Jul 1st 2013, 9:15pm)

3 339

by mrfixit

(Jul 2nd 2013, 3:07am)

by rrsteve (Aug 22nd 2002, 9:53pm)

1 343

by Rays Sprinklers

(May 22nd 2003, 4:13am)

by mijd (Jul 20th 2011, 2:56pm)

2 344

by Mitchgo

(Jul 23rd 2011, 3:45am)

by bbruck (Jun 20th 2009, 7:11pm)

1 344

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 346

by hi.todd

(Feb 27th 2011, 4:12pm)

by joe13 (Aug 19th 2012, 12:36pm)

1 348

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by tico (Jun 15th 2013, 8:58pm)

0 355

No reply

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)