You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Texas_Pete (May 1st 2005, 7:21pm)

1 427

by Wet_Boots

(May 2nd 2005, 2:02am)

by hettiep (May 27th 2005, 5:02am)

2 428

by Jazzer K

(Sep 2nd 2005, 6:22pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 429

by GatorGuy

(May 21st 2012, 9:04am)

by Stu1986 (May 5th 2012, 11:44pm)

3 429

by mrfixit

(May 6th 2012, 1:23pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 430

by hi.todd

(Jun 19th 2009, 10:24pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 430

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 436

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 436

by Wet_Boots

(Sep 16th 2007, 7:55am)

by rrsteve (Aug 22nd 2002, 9:53pm)

1 436

by Rays Sprinklers

(May 22nd 2003, 4:13am)

by bbruck (Jun 20th 2009, 7:11pm)

1 443

by Wet_Boots

(Jun 21st 2009, 8:31am)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)