You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Sue (Aug 11th 2005, 10:47am)

4 445

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 450

by Mitchgo

(Jul 25th 2011, 11:12pm)

by handan (Nov 30th 2011, 11:30pm)

2 453

by handan

(Dec 2nd 2011, 4:56am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 457

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by bobottolini (Jul 10th 2006, 12:27pm)

3 461

by jmduke7

(Aug 16th 2006, 6:30pm)

by eddieruko (Jul 29th 2014, 4:52pm)

2 463

by eddieruko

(Jul 30th 2014, 12:31pm)

by Terri (Jan 9th 2013, 6:46am)

1 463

by Wet_Boots

(Jan 9th 2013, 11:08am)

by blh (Jun 4th 2011, 12:55pm)

1 463

by Mitchgo

(Jun 4th 2011, 3:32pm)

by Rmiclette (May 5th 2013, 6:49am)

2 468

by Scott76

(May 5th 2013, 11:41am)

by waboehly (May 1st 2007, 6:51am)

1 471

by Tom

(May 1st 2007, 3:34pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)