You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fbg (Aug 13th 2015, 4:40pm)

1 494

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 1,237

by crashxx

(May 1st 2012, 9:15am)

by John199 (Aug 14th 2011, 3:57pm)

4 1,267

by hi.todd

(Aug 15th 2011, 7:29pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 4,270

by Mitchgo

(Jun 12th 2011, 2:13pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,471

by jmduke7

(Aug 17th 2006, 3:00pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 1,052

by mrfixit

(Nov 10th 2011, 4:23am)

by cmoore (Mar 27th 2016, 6:32am)

3 254

by Wet_Boots

(Apr 2nd 2016, 10:52am)

by mydogcleo (Aug 28th 2013, 10:11am)

1 487

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by LT87 (May 21st 2014, 11:33am)

3 283

by hi.todd

(May 27th 2014, 1:03pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 760

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

Show

Statistics:

506 Threads - 1,938 Posts (average 0.37 Posts per Day)