You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rickesco (Jul 28th 2004, 8:13am)

3 136

by aquamatic

(Jul 29th 2004, 10:36am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 205

by mrfixit

(Jun 4th 2010, 7:49pm)

by DAVID LP (Jul 18th 2011, 10:55am)

2 319

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 153

by ahersman

(Sep 30th 2009, 6:15pm)

by kingtpt (Jul 17th 2010, 5:57pm)

5 163

by Fireguy97

(Jul 18th 2010, 11:35pm)

by macminn (May 18th 2007, 5:05pm)

9 302

by SprinklerGuy

(May 25th 2007, 3:19am)

by dgergits (Aug 29th 2010, 10:02am)

0 321

No reply

by jrb (Jul 5th 2011, 7:11pm)

2 879

by hi.todd

(Jul 12th 2011, 6:46pm)

by OscarNav (Apr 17th 2005, 8:54pm)

2 345

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by aziz786 (Aug 9th 2010, 12:02pm)

2 166

by aziz786

(Aug 10th 2010, 12:49pm)

Show

Statistics:

421 Threads - 1,570 Posts (average 0.36 Posts per Day)