You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by keitht (Apr 11th 2006, 3:53pm)

1 166

by BSME

(Apr 12th 2006, 5:45am)

by Bob H (May 13th 2003, 12:54am)

17 543

by Bob H

(Jun 3rd 2003, 9:20am)

by rickesco (Jul 28th 2004, 8:13am)

3 141

by aquamatic

(Jul 29th 2004, 10:36am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 215

by mrfixit

(Jun 4th 2010, 7:49pm)

by DAVID LP (Jul 18th 2011, 10:55am)

2 334

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 154

by ahersman

(Sep 30th 2009, 6:15pm)

by Texas Tarheel (Jun 19th 2014, 8:33pm)

8 70

by irrigirl

(Jun 24th 2014, 12:26pm)

by kingtpt (Jul 17th 2010, 5:57pm)

5 165

by Fireguy97

(Jul 18th 2010, 11:35pm)

by macminn (May 18th 2007, 5:05pm)

9 319

by SprinklerGuy

(May 25th 2007, 3:19am)

by dgergits (Aug 29th 2010, 10:02am)

0 356

No reply

Show

Statistics:

427 Threads - 1,618 Posts (average 0.36 Posts per Day)