You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by chpsk8 (Mar 17th 2002, 5:25am)

1 427

by RVLI

(Mar 20th 2002, 12:31pm)

by JT (Mar 9th 2014, 8:08pm)

2 511

by scbsprinkler

(May 6th 2016, 8:32pm)

by Grady (Apr 30th 2016, 9:52pm)

2 97

by Wet_Boots

(May 1st 2016, 10:54am)

by BayAreaFlyer (Feb 9th 2016, 2:17pm)

2 466

by Wet_Boots

(Feb 9th 2016, 5:28pm)

by PAP (Aug 19th 2015, 10:04am)

2 597

by PAP

(Sep 8th 2015, 9:57am)

by GT6812 (Aug 28th 2015, 8:40am)

2 397

by GT6812

(Aug 31st 2015, 11:15am)

by trs (Aug 4th 2015, 7:38pm)

2 575

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 158

by LX2

(Jul 17th 2015, 8:27am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 219

by Eowilcox

(Jun 18th 2015, 2:23pm)

by zsac09 (Jun 8th 2015, 2:57pm)

2 268

by zsac09

(Jun 10th 2015, 3:26pm)

Show

Statistics:

500 Threads - 1,910 Posts (average 0.37 Posts per Day)