You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by LX2 (Jul 16th 2015, 3:14pm)

2 93

by LX2

(Jul 17th 2015, 8:27am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 150

by Eowilcox

(Jun 18th 2015, 2:23pm)

by zsac09 (Jun 8th 2015, 2:57pm)

2 180

by zsac09

(Jun 10th 2015, 3:26pm)

by EricJRW (May 6th 2015, 8:09pm)

2 145

by EricJRW

(May 7th 2015, 7:04am)

by jerr7 (May 4th 2015, 4:35pm)

2 87

by jerr7

(May 6th 2015, 11:08am)

by fouracreDon (Mar 17th 2015, 8:09am)

2 236

by carlanw

(Apr 27th 2015, 10:52pm)

by wileyb (Mar 23rd 2015, 4:00pm)

2 646

by Wet_Boots

(Mar 24th 2015, 9:18am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 464

by eddieruko

(Jul 30th 2014, 12:31pm)

by Benmt (Jul 24th 2014, 11:01pm)

2 215

by Benmt

(Jul 25th 2014, 1:46pm)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,899

by mrfixit

(Aug 26th 2013, 8:00pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)