You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by George_S (Jun 26th 2009, 7:13pm)

0 198

No reply

by EtzGx (Jun 21st 2009, 12:40pm)

0 464

No reply

by bbruck (Jun 20th 2009, 7:11pm)

1 329

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 175

by hi.todd

(Jun 19th 2009, 10:29pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 123

by hi.todd

(Jun 19th 2009, 10:27pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 302

by hi.todd

(Jun 19th 2009, 10:24pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 146

by hi.todd

(Jun 19th 2009, 10:23pm)

by larbec7 (Jun 6th 2009, 5:07pm)

9 865

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by killerj (May 25th 2009, 10:32am)

0 188

No reply

by Jeff Nobles (May 21st 2009, 9:40am)

3 493

by hi.todd

(May 22nd 2009, 8:19pm)

Show

Statistics:

434 Threads - 1,638 Posts (average 0.36 Posts per Day)