You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lawnnovice (Jul 5th 2010, 3:03pm)

3 852

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by paul b (Jul 3rd 2010, 10:24am)

1 417

by Wet_Boots

(Jul 6th 2010, 9:21am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 124

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by svsprinklers (May 19th 2010, 9:29pm)

2 951

by PhoenixDen

(Jun 24th 2010, 11:27am)

by Kim (Jun 19th 2010, 6:45am)

1 172

by mrfixit

(Jun 19th 2010, 12:11pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 158

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 189

by mrfixit

(Jun 4th 2010, 7:49pm)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,198

by mrfixit

(Jun 2nd 2010, 2:27am)

by Merv (May 1st 2010, 3:44pm)

3 276

by mrfixit

(May 31st 2010, 9:47pm)

by KSknight (Aug 17th 2009, 10:53am)

1 617

by bdbengtsson

(May 21st 2010, 5:27pm)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)