You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by JohnEmery (Jul 31st 2011, 3:48pm)

1 583

by Wet_Boots

(Jul 31st 2011, 4:16pm)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 706

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 1,158

by squints

(Jul 31st 2011, 2:16pm)

by JimB (Jul 30th 2011, 3:59pm)

1 271

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 454

by Mitchgo

(Jul 25th 2011, 11:12pm)

by mijd (Jul 20th 2011, 2:56pm)

2 513

by Mitchgo

(Jul 23rd 2011, 3:45am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 831

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by irar (Jul 11th 2011, 5:27pm)

4 619

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by (Jul 18th 2011, 5:26pm)

1 605

by Mitchgo

(Jul 19th 2011, 12:34am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 703

by Wet_Boots

(Jul 18th 2011, 12:19pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)