You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Emblazed (Jul 24th 2010, 10:30am)

5 412

by Wet_Boots

(Jul 27th 2010, 10:48am)

by fragnus (Jul 25th 2010, 9:45pm)

3 1,144

by Wet_Boots

(Jul 27th 2010, 8:25pm)

by slemani62 (Jul 29th 2010, 2:56pm)

1 564

by mrfixit

(Jul 29th 2010, 6:35pm)

by frankmanic (Aug 5th 2010, 8:44am)

0 201

No reply

by Fisher (Aug 7th 2010, 5:43pm)

0 122

No reply

by daniels (Aug 7th 2007, 11:14am)

5 3,179

by MrMark757

(Aug 9th 2010, 2:36am)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 695

by hi.todd

(Aug 10th 2010, 11:57am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 176

by aziz786

(Aug 10th 2010, 12:49pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 571

by mrfixit

(Aug 12th 2010, 5:12pm)

by beanpole (Aug 21st 2010, 10:20pm)

5 762

by Wet_Boots

(Aug 24th 2010, 12:57pm)

Show

Statistics:

427 Threads - 1,618 Posts (average 0.36 Posts per Day)