You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by cassian (Jul 31st 2005, 2:39pm)

4 342

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by gobris (May 14th 2013, 9:45am)

3 341

by Wet_Boots

(May 16th 2013, 8:30am)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 341

by mrfixit

(Jul 14th 2012, 12:39am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 340

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by miker (Apr 30th 2011, 12:53pm)

1 338

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by irar (Jul 11th 2011, 5:27pm)

4 337

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by tmshead (Oct 1st 2007, 4:35am)

2 336

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 335

by GatorGuy

(Mar 14th 2012, 7:35am)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 330

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 330

by Wet_Boots

(Jul 31st 2011, 3:08pm)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)