You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by desmo907 (Aug 28th 2012, 3:54pm)

3 685

by desmo907

(Sep 4th 2012, 8:33am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 685

by Mitchgo

(Jul 19th 2011, 12:34am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 679

by Brassguy

(Mar 8th 2012, 10:09pm)

by sgb (Jun 5th 2006, 5:30pm)

0 679

No reply

by Pippilo (Jul 1st 2013, 9:15pm)

3 673

by mrfixit

(Jul 2nd 2013, 3:07am)

by Leah Heimdahl (May 4th 2006, 4:47pm)

4 669

by DOORZ

(May 31st 2006, 6:50am)

by PAP (Aug 19th 2015, 10:04am)

2 667

by PAP

(Sep 8th 2015, 9:57am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 663

by GatorGuy

(Mar 14th 2012, 7:35am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 662

by hi.todd

(Feb 27th 2011, 4:12pm)

by Bert Wall (Jan 23rd 2007, 7:40am)

5 662

by Wet_Boots

(Jan 25th 2007, 12:56pm)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)