You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rcajun36 (Jun 26th 2006, 5:13am)

3 2,087

by xpedient

(Jun 26th 2006, 6:53am)

by paul b (Jul 3rd 2010, 10:24am)

1 658

by Wet_Boots

(Jul 6th 2010, 9:21am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 702

by Brassguy

(Mar 8th 2012, 10:09pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 576

by Wet_Boots

(May 2nd 2005, 2:02am)

by wjmoore (Aug 1st 2004, 8:04am)

2 1,816

by nestors

(Oct 31st 2004, 1:30pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 655

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by JimB (Jul 30th 2011, 3:59pm)

1 337

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 276

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 1,188

by jmduke7

(Aug 17th 2006, 3:13pm)

by brobinson (Jun 12th 2010, 7:44am)

8 2,908

by Wet_Boots

(Mar 31st 2012, 4:43pm)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)