You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by John199 (Aug 14th 2011, 3:57pm)

4 1,143

by hi.todd

(Aug 15th 2011, 7:29pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 3,638

by Mitchgo

(Jun 12th 2011, 2:13pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,385

by jmduke7

(Aug 17th 2006, 3:00pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 958

by mrfixit

(Nov 10th 2011, 4:23am)

by mydogcleo (Aug 28th 2013, 10:11am)

1 452

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by LT87 (May 21st 2014, 11:33am)

3 259

by hi.todd

(May 27th 2014, 1:03pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 592

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by Fapp (Feb 21st 2005, 10:11am)

3 922

by nestors

(Apr 7th 2005, 8:51am)

by fireman (Sep 15th 2006, 3:14pm)

8 845

by mrfixit

(Sep 19th 2006, 9:59am)

by 206007075 (Sep 28th 2004, 10:26am)

0 590

No reply

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)