You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by patk (Sep 18th 2011, 2:17pm)

2 636

by patk

(Sep 18th 2011, 3:41pm)

by tbatrof (Sep 10th 2011, 7:00pm)

2 251

by mrfixit

(Sep 10th 2011, 10:07pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 165

by evergreenz

(Sep 3rd 2011, 12:08pm)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 139

by Wet_Boots

(Aug 23rd 2011, 11:43am)

by fwoodall (Aug 28th 2005, 6:01pm)

2 897

by squints

(Jul 31st 2011, 2:16pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 312

by Mitchgo

(Jul 25th 2011, 11:12pm)

by mijd (Jul 20th 2011, 2:56pm)

2 344

by Mitchgo

(Jul 23rd 2011, 3:45am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 386

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 241

by Mitchgo

(Jul 11th 2011, 12:24am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 634

by ddeferra

(Jun 8th 2011, 6:29pm)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)