You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by RonBLaGrone (Jun 4th 2013, 11:05am)

2 646

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by Rmiclette (May 5th 2013, 6:49am)

2 451

by Scott76

(May 5th 2013, 11:41am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 463

by Ianjanson

(Apr 10th 2013, 7:37pm)

by rockypoint (Nov 26th 2012, 6:02pm)

2 725

by mrfixit

(Nov 26th 2012, 7:30pm)

by lalloo (Aug 5th 2012, 11:02am)

2 317

by GatorGuy

(Aug 6th 2012, 9:13am)

by Bonelawr (Jul 29th 2012, 9:45am)

2 311

by Bonelawr

(Jul 29th 2012, 11:38am)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 355

by GatorGuy

(Jul 3rd 2012, 8:00am)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 863

by GatorGuy

(Jun 12th 2012, 8:36am)

by dse (Jun 8th 2012, 5:58am)

2 525

by Wet_Boots

(Jun 8th 2012, 8:48am)

by AdamT (Jun 7th 2012, 12:00pm)

2 368

by AdamT

(Jun 7th 2012, 9:14pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)