You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 144

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 368

by mulletmac

(Oct 1st 2011, 11:26am)

by danny1949 (Sep 22nd 2011, 12:04pm)

1 203

by Wet_Boots

(Sep 22nd 2011, 5:05pm)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 370

by CRI IRR

(Sep 13th 2011, 6:34am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 232

by mrfixit

(Sep 10th 2011, 10:07pm)

by maddog (Sep 8th 2011, 5:48pm)

1 174

by grey

(Sep 9th 2011, 11:40am)

by Jimy (Aug 30th 2011, 11:45am)

4 497

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 147

by evergreenz

(Sep 3rd 2011, 12:08pm)

by chrisrlewis78 (Aug 4th 2011, 6:51pm)

18 1,803

by chrisrlewis78

(Aug 31st 2011, 4:50pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 898

by Central Irrigation

(Aug 30th 2011, 8:38pm)

Show

Statistics:

432 Threads - 1,632 Posts (average 0.36 Posts per Day)