You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ohiorebel (Apr 10th 2011, 8:59am)

2 285

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by orgits (Apr 9th 2011, 5:10pm)

2 547

by Mitchgo

(Apr 10th 2011, 2:29am)

by denm31 (Apr 4th 2011, 3:11pm)

6 443

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by stellar495 (Mar 17th 2011, 8:57pm)

3 1,454

by hi.todd

(Mar 20th 2011, 11:03am)

by joe decoste (Mar 19th 2011, 11:56am)

1 165

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 313

by hi.todd

(Feb 27th 2011, 4:12pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 376

by mrfixit

(Dec 4th 2010, 1:48pm)

by quick11 (Oct 7th 2010, 10:53am)

3 367

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by william62949 (Oct 10th 2010, 2:56pm)

1 260

by mrfixit

(Oct 10th 2010, 6:02pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 169

by Wet_Boots

(Sep 28th 2010, 1:11pm)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)