You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ianmac (Apr 25th 2011, 10:45pm)

1 561

by Wet_Boots

(Apr 26th 2011, 9:20am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 393

No reply

by wrx884 (Apr 22nd 2011, 12:57am)

5 1,145

by Wet_Boots

(Apr 25th 2011, 9:37am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 270

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 170

No reply

by ohiorebel (Apr 10th 2011, 8:59am)

2 286

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by orgits (Apr 9th 2011, 5:10pm)

2 565

by Mitchgo

(Apr 10th 2011, 2:29am)

by denm31 (Apr 4th 2011, 3:11pm)

6 458

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by stellar495 (Mar 17th 2011, 8:57pm)

3 1,472

by hi.todd

(Mar 20th 2011, 11:03am)

by joe decoste (Mar 19th 2011, 11:56am)

1 170

by Wet_Boots

(Mar 20th 2011, 7:29am)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)