You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by svsprinklers (May 19th 2010, 9:29pm)

2 1,004

by PhoenixDen

(Jun 24th 2010, 11:27am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 141

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by paul b (Jul 3rd 2010, 10:24am)

1 447

by Wet_Boots

(Jul 6th 2010, 9:21am)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 1,009

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 169

by hi.todd

(Jul 12th 2010, 12:49pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 174

by Wet_Boots

(Jul 17th 2010, 9:11am)

by kingtpt (Jul 17th 2010, 5:57pm)

5 173

by Fireguy97

(Jul 18th 2010, 11:35pm)

by ssherrid (Jul 21st 2010, 12:18am)

0 439

No reply

by AJ Goldsmith (Jul 21st 2010, 2:48pm)

1 1,668

by Wet_Boots

(Jul 21st 2010, 7:36pm)

by Frankpc (Jul 22nd 2010, 9:02pm)

0 869

No reply

Show

Statistics:

430 Threads - 1,624 Posts (average 0.36 Posts per Day)