You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 768

by mrfixit

(Jul 14th 2012, 12:39am)

by dkraska (Aug 29th 2009, 2:41pm)

4 766

by hi.todd

(Aug 30th 2009, 9:32pm)

by cassian (Jul 31st 2005, 2:39pm)

4 756

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by spensito (Feb 16th 2006, 6:52am)

7 755

by lush96

(Mar 19th 2006, 7:16pm)

by macminn (Jun 11th 2007, 5:43pm)

2 748

by mrfixit

(Jun 7th 2008, 8:13am)

by Pippilo (Jul 1st 2013, 9:15pm)

3 746

by mrfixit

(Jul 2nd 2013, 3:07am)

by Marlene (Aug 23rd 2007, 3:11am)

4 746

by Marlene

(Aug 25th 2007, 5:42am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 735

by Mitchgo

(Jul 19th 2011, 12:34am)

by OscarNav (Apr 17th 2005, 8:54pm)

2 729

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 728

by Wet_Boots

(Jun 9th 2011, 9:05pm)

Show

Statistics:

516 Threads - 1,973 Posts (average 0.37 Posts per Day)